ARIS ARCHITECT
QUICK START GUIDE

VERSION 10.0 - SERVICE RELEASE 6
October 2018
Contents

1 Text conventions ................................................................................................................................. 1
2 Before you start ...................................................................................................................................... 2
3 Prepare .................................................................................................................................................. 4
   3.1 Start ARIS Architect ......................................................................................................................... 4
   3.2 Create database ................................................................................................................................ 5
4 Model ..................................................................................................................................................... 6
   4.1 Create a model ..................................................................................................................................... 7
   4.2 Show print pages in the model window ............................................................................................... 9
   4.3 Specify connection settings ............................................................................................................... 11
   4.4 Create objects and object attributes ................................................................................................. 12
   4.5 Create object occurrences ............................................................................................................... 18
   4.6 Rename objects ................................................................................................................................... 20
   4.7 Arrange and group objects ............................................................................................................... 21
   4.8 Create connections .......................................................................................................................... 23
   4.9 Create links ....................................................................................................................................... 24
      4.9.1 Create a program shortcut ......................................................................................................... 24
      4.9.2 Create a hyperlink ....................................................................................................................... 26
   4.10 Place attributes ............................................................................................................................... 28
   4.11 Apply template .................................................................................................................................. 31
   4.12 Save model ....................................................................................................................................... 33
5 Evaluate .................................................................................................................................................. 34
   5.1 Print model ......................................................................................................................................... 34
      5.1.1 Configure header and footer ...................................................................................................... 34
      5.1.2 Specify print scale and color ..................................................................................................... 36
      5.1.3 Start printing .............................................................................................................................. 36
   5.2 Evaluate model contents .................................................................................................................. 37
   5.3 Close model ....................................................................................................................................... 39
6 Legal information .................................................................................................................................... 40
   6.1 Documentation scope ....................................................................................................................... 40
   6.2 Data protection ................................................................................................................................... 41
   6.3 Disclaimer .......................................................................................................................................... 41
1 Text conventions

Menu items, file names, etc. are indicated in texts as follows:

- Menu items, key combinations, dialogs, file names, entries, etc. are displayed in **bold**.
- User-defined entries are shown `<in bold and in angle brackets>`.
- Single-line example texts (for example, a long directory path that covers several lines due to a lack of space) are separated by ◆ at the end of the line.
- File extracts are shown in this font format:
  This paragraph contains a file extract.
- Warnings have a colored background:
  
  **Warning**
  This paragraph contains a warning.
2  

Before you start

This Quick Start Guide introduces you to the basic functions of ARIS Architect. Using simple examples, you learn about important workflows for creating models, as well as for evaluating model content.

After specifying the required settings, you will first create a model of the EPC type and then evaluate it with a report.

Your work with ARIS Architect can be divided into the following phases:

Prepare

- Start ARIS Architect
- Create database

Model

- Create model
- Specify model settings
- Create objects, connections and attributes
- Influence model appearance
- Save model

Evaluate

- Print model
- Evaluate model content

The Quick Start Guide guides you step by step through the required workflow. If you have questions about working with ARIS Architect, you can use the online help:

- If you need help with an open dialog, click the Help button of the dialog.
- If you require additional information, click ARIS > Help in the menu bar.
- If you need method help you can press the Ctrl + F1 keys at many points in the program; the Method help opens. If, for example, you have opened a model of the EPC type and press Ctrl + F1, the EPC type will be explained. If you have selected an object while pressing the Ctrl + F1 keys, the Method help for this object is opened instead.

The screen graphics in this manual may differ from your program interface, because different functions may be provided in ARIS Architect depending on your license.
PREREQUISITES

To make optimum use of this Quick Start Guide, you should be able to access the standard filter and user settings from ARIS Architect. In addition, it is assumed that your system administrator provided you with a link to the download client and that you, as a user, were created with the necessary privileges in the system. In case of doubt, please contact your system administrator.
3 Prepare

In this chapter you will find information about the program start and the preparations you must make before modeling.

3.1 Start ARIS Architect

This description assumes that as a user you log in with a ARIS Architect license.

Procedure

1. Enter the link for the download client in the address bar of your browser. This link should have been provided to you by your system administrator.

2. Select **ARIS Architect/Designer** and click **Start**. A JAR archive is displayed, which can be directly opened or saved, depending on the browser you are using. If you have saved the JAR archive, you can start ARIS Architect directly by double-clicking this file in the future.

3. Log in with the user ID provided to you.

ARIS Architect opens.

If the link does not work please contact your system administrator.
3.2 Create database

In the following, you will create a database to save the data that you will generate while working through the Quick Start Guide.

Procedure
1. Activate the Explorer tab.
2. Make sure that the Navigation bar is displayed.
3. Right-click your server and select New > Database.
4. The Create database dialog opens. Enter Sales and Marketing as database name and leave the check box Versionable deactivated.
5. Click OK.
6. Right-click the database and click Log in. Log in with the Demo filter.

You have created the Sales and Marketing database and logged into it.
4 Model

The following pages explain how you can display content using a model of the **EPC** type.

Your **Customer acquisition** EPC will appear as follows when finished:
4.1 Create a model

To create the **Customer acquisition** EPC, proceed as follows.

**Procedure**

1. Click the arrow next to the **Sales and Marketing** database in the **Navigation** bar. The **Main group** folder is displayed, in which you store the new model.

2. Click **Main group** and then click **New > Model**.

The Model Wizard opens. Enable **Processes**.

![Model Wizard](image)

The models are assigned to the descriptive views **Organization**, **Data**, **Processes**, **Functions** and **Product/Service**. The list shows all model types that are assigned to the selected descriptive views and are allowed by the selected method filter. Please refer to the **ARIS Method** manual for a detailed description of the ARIS architecture and an explanation of the descriptive views and levels.

3. Click **EPC** in the **Model types** box.

4. Enter the name **Customer acquisition** in the **Name** box.

5. Click **OK**. The **Customer acquisition** model is generated and automatically opens.

6. Hide all bars except **Symbols** by disabling all bars in the bar panel except **Symbols**.

   You can show the panes again at any time for navigation or for editing object properties.
The model window, various toolbars and various buttons are now available for creating your model.
4.2 Show print pages in the model window

To predefine which parts of your model are to be placed on which print page, you can delimit the print pages displayed in the model window using red dashed lines.

Procedure

1. Click Grid if no grid is displayed in the model.
2. Click ARIS > Options.
3. On the Selection tab, click Model > General > Print.
4. Enable the Show print pages check box.
5. Click OK.
6. Click ARIS > Print > Print preview.
7. Enable the **Portrait** option button.
8. Click **Close**.

The individual print pages are now indicated as portraits by red dashed lines in the model window. Thus, you can ensure optimal object placement for the printout while modeling.

The settings that you specify with the **ARIS > Options** menu item in the **Model > General** area affect all models. However, settings specified in the **Model > For new models** area apply to new models only.
4.3 Specify connection settings

In the following you will specify that straight connections can also be created in your model.

Procedure
1. Click in the model background and activate the Format tab bar.
2. Click Representation > Connections.
3. Click Connections.
4. Disable the New connections only right-angled check box.
5. Click OK.

You can now also create straight connections in your model.

If you want to create straight connections in all of your new models, click ARIS > Options and Model > For new models > Connections on the Selection tab. Disable the New connections only right-angled check box.
4.4 Create objects and object attributes

In this section, you will place objects in your model and edit object attributes.

Procedure

1. Right-click in the Symbols bar and select Symbols with names to display the symbol names in addition.

2. Click the Event symbol in the Symbols bar.

3. Move the mouse pointer to the model and click again. The event is created and a text box opens automatically.

4. Enter a name for the event by overtyping the selection with Launch scheduled. To insert a line break between Launch and scheduled, press Enter.

5. Click in the model background and then on the Launch scheduled event. The mini toolbar is displayed under the event. It provides you with object symbols, connections and rules that you can link to the selected object. If you do not want the mini toolbar to be shown for a selected object, move the mouse pointer a few centimeters away from the selected object. It will then only be shown when you select it again.
6. Click the **Function** symbol in the mini toolbar.

7. The connections allowed by the method are displayed. Keep the **Launch scheduled activates Function** connection activated and click below the **Launch scheduled** event in the model window.

   ![Diagram of connections](image)

   Overtype **Function** with **Find addresses of potential customers**.

8. Create the following objects one below the other using the mini toolbar, while keeping the respective connection default:
   a. Event: Addresses of customers found
   b. Function: Find contact person
   c. Event: Contact person found
   d. Function: Schedule product presentation
   e. Event: Product presentation scheduled

   For longer names in an object symbol to be properly broken down, you can insert conditional separators. To do so, press **Ctrl + Hyphen (-)**. Conditional separators are displayed only if a name really needs to be broken down. As soon as you enlarge the object and the name fits within without a line break, the separator will be removed again.

9. If all objects are not displayed in the model window, decrease the representation of the model. Activate the **View** tab bar and click **Zoom out**.

   Alternatively, click **Zoom > Custom** in the **View** tab bar and enter the relevant zoom factor, for example, 85.
10. Click the **Find addresses of potential customers** function and then the **Add symbols** button in the mini toolbar.

11. The **Add symbols** dialog opens. Double-click the **Organizational unit** symbol.

The symbol is inserted into the mini toolbar.

12. Double-click in the dialog on the **Application system type** symbol to insert it into the mini toolbar.

13. Finally, click **Close** to close the dialog.
14. You will create the next symbol to the left of the selected function *Find addresses of potential customers*. If there is not enough space, insert space to the left of the selected function:
   a. Activate the Insert tab bar.
   b. Click \[\text{Horizontal space}\].
   c. In the model window, click the position starting from which you want to insert space (from left to right), and hold down the mouse button.
   d. Drag the visible line to the right and release the mouse button at the position where you want to stop inserting space.
   
   The model items positioned within the area indicated by the start and end lines are placed to the right of the end line. The connections are adjusted.

15. Now click the Application system type symbol in the mini toolbar and then to the left of the selected function *Find addresses of potential customers* click in the model background.

16. Name the new object **CRM system**.

17. Click the Find addresses of potential customers function again and create an organizational unit to the right of the function. Name it **Sales**.

18. Click the Sales object and click \[\text{Attributes}\] in the Start tab bar. Attribute Editing opens.

19. In the tree view, click **Simulation**.
20. Finally, in the table enter the value **12** as the **Number of employees** in the column **Sales (English)**.

21. Click **Close** and confirm the query with **Yes**.
Your EPC should look like this now:

Tips
- To change attributes for multiple objects, select the objects, right-click in the selection and select \textit{Attributes}. The selected objects of each object type are summarized on individual tabs.
- To remove the symbol from the mini toolbar, right-click the symbol, and select \textit{Remove symbol}.
4.5 Create object occurrences

The Sales organizational unit is also responsible for the Find contact person and Schedule product presentation functions. To structure your model clearly, you can create an occurrence of the Sales object beside each of these functions. Object occurrences are copies of object symbols that represent the same object in one or more models. Any occurrence of the Sales object that you create will represent the object you have already created in your model. If you change an occurrence, the changes will apply to all occurrences. This becomes apparent if you change the name of the object.

Procedure

1. Right-click Sales, hold down the mouse button and move the pointer to the right of the Find contact person function. Release the mouse button and click Create occurrence copy here. Another symbol is created in the model for the Sales object. The symbol is not linked to the function with a connection yet.

2. Create the next occurrence copy with the mini toolbar. To do so, click the Schedule product presentation function and create an organizational unit to the right of the function. Name it Sales. As soon as you are finished with your input, the Select object dialog opens.

3. Double-click the Sales object. The new organizational unit is created in the model as an occurrence of the selected object.
Your EPC should look like this now:

1. **Launch scheduled**
2. **CRM system**
3. **Find addresses of potential customers**
4. **Addresses of customers found**
5. **Find contact person**
6. **Contact person found**
7. **Schedule product presentation**
8. **Product presentation appointed**
9. **Sales**
4.6 Rename objects

You can change object names directly in the model. If you change a name, all occurrences of the object in the database are renamed accordingly.

In the following, you will change the name of the Sales organizational unit.

Procedure
1. Click one of the three Sales symbols.
2. Click Rename in the Start tab bar.
3. Enter Distribution and click in the model background.

The name of the organizational unit is now Distribution and all occurrences of the object are displayed with the new name.
4.7 Arrange and group objects

Now, you will arrange the symbols in the model.

Procedure

1. Select the adjacent objects **CRM system**, **Find addresses of potential customers** and **Distribution**. To do so, position the mouse pointer to the left of/above the **CRM system** object, press and hold the left mouse button, and drag the mouse pointer to the right of/below the **Distribution** object. This completely encloses the adjacent objects **CRM system**, **Find addresses of potential customers** and **Distribution** within the displayed frame. Now release the mouse button. The objects are selected.

2. Click **Align > Align middle** in the **Start** tab bar.

3. Click **Align > Distribute horizontally**.

4. Activate the **Format** tab bar and click **Group**. You can now move or edit the three grouped objects together only.

5. Right-click in the model background and select **Select > All**.

6. Hold down the **Ctrl** key and successively click the two new occurrences of the **Distribution** organizational unit. The symbols are now removed from the selection. Release the **Ctrl** key.

7. Activate the **Start** tab bar and click **Align > Centered**.

8. Click **Align > Distribute vertically**.

9. Click in the model background to deselect all symbols.

10. Increase the distance between the **CRM system** application type and the **Find addresses of potential customers** function. To move the grouped objects separately, you must first ungroup them. Activate the **Format** tab bar and click **Group > Ungroup**.

11. Right-click in the model background and select **Select > All**.

12. Hold down the **Ctrl** key and click **CRM system**. The object is removed from the selection.

13. Now you can move the selected objects to the right by increments of two gridlines. To do this, hold down the **Shift key** and press the **right arrow key** twice. The selected objects are moved in line with the grid steps.

14. Click in the model background to deselect all symbols.

15. Arrange the **Distribution** object occurrences. Right-click one of the object occurrences and enable **Select > Select all of this type**. The symbols are selected.

16. Click **Align > Align right**.

17. Click in the model background to deselect all symbols.

18. Hold down the **Ctrl** key and successively click **Find contact person** and the **Distribution** organizational unit placed to the right. The symbols are selected.

19. Click **Align > Align bottom**.

20. Click in the model background to deselect all symbols.
21. Now align the **Schedule product presentation** objects and the organizational unit **Distribution** to the right of it along a bottom line. The objects of the model are now arranged as follows:

![Diagram](image)

**Tips**
- If your model is no longer fully visible in the model window, reduce the size of the model's appearance. To do this, select the current value in the **Size of appearance** field of the toolbar and overwrite it with 80, for example. Press **Enter**.
- To move the model in the model window, right-click in the model background and select **Select > Select all**. Click anywhere in the selection, hold down the mouse button, and drag the model to the relevant position in the model window.
4.8 Create connections

In the following, you will link the unconnected object of your Customer acquisition model with another object via a connection.

Procedure

1. Click **Toggle connection mode** in the toolbar. If the mouse pointer is now located on the border of an object, connection anchor points are displayed.

2. Move the mouse pointer over the left border of the Distribution organizational unit which is not yet linked with a connection. A connection anchor point is displayed.

3. Click the anchor point, and move the mouse pointer to the right border of the Find contact partner function.

4. Clicking the anchor point that appears at the function will connect the two objects.

Tip

The following shape indicates that you are moving the mouse pointer over a target object for which the method does not allow connections.

This may occur if you attempt to draw a connection from the Launch scheduled event to the CRM system or Distribution objects, for example.
4.9 Create links

You can link objects in ARIS Architect with Web sites or e-mail addresses via hyperlinks. This enables you to access Web sites or send e-mails directly from ARIS Architect. You can also link objects with programs like Microsoft® Excel, Microsoft® Word, or Microsoft® PowerPoint, and run these directly from ARIS Architect.

4.9.1 Create a program shortcut

To link the CRM system object with a program (for example, Microsoft® Excel), proceed as follows:

Procedure

1. Click the CRM system object and select Attributes. The Attributes dialog opens.
2. In the tree view, click the System attributes attribute type group.
3. Click in the cell of the Title 1 row and enter the program name (for example, Microsoft® Excel).
4. Enter the path to the executable program file (for example, C:\Program Files\Microsoft Office\Office14\EXCEL.EXE) in the Link 1 cell. You can also click the Browse button and navigate to the relevant directory.
5. Click **Save** to save the attribute changes.
6. Click **Close**.
7. Click the **CRM system** object.
8. Click **Go to > Link** in the **Start** tab bar.
   The linked program is launched.
9. Close the program.
4.9.2 Create a hyperlink

To link the Distribution object with a Web site, proceed as follows:

Procedure

1. Click an occurrence of the Distribution organizational unit and then click Attributes. The Attributes dialog opens.

   Each row in the table corresponds with an attribute. The name of the Distribution object refers to the column that contains all of the object's attribute values. The object name is followed by the language in which the language-dependent attribute values are specified. In this case, this is English. The values in gray cells cannot be edited. You can change the column width by clicking a dividing line in the column header, holding down the mouse button and moving the line.

2. Click the Organizational unit tab on the System attributes attribute type group.

3. Click in the cell of the Title 1 attribute and enter Software AG as the name of the hyperlink.

4. Click the cell of the Link 1 attribute and enter the address www.softwareag.com.
5. Click Save to save the attribute changes.
6. Click Close.
7. Click an occurrence of the Distribution organizational unit.
8. Click Go to > Link in the Start tab bar. Your Internet browser is launched and the Software AG Web site opens.
9. Close your Internet browser.
You have created a link for the Distribution object.
4.10 Place attributes

You can display the attributes of objects and connections in your model. Now, you will display the connection type.

Procedure

1. Select the connection between the **CRM system** object and the connections between the **Distribution** organizational unit and the assigned functions. To do so, press and hold down the Ctrl key and click the connections one after the other. Then release the Ctrl key.

2. Click **Properties** in the **Start** tab bar. The **Properties** dialog opens.

3. In the tree view, click **Attribute placement (connections)**.

4. Click **Add**. The **Add attributes** dialog opens. Specified attributes are marked with a symbol ( Griffel ) in the list.
   
   Double-click the **Type** attribute. The dialog is closed and the attribute is transferred to the **Properties** dialog. Since the **Type** attribute is the only placed attribute, it is already selected.

5. Enable the lower middle check box in the **Placement** area.

6. Ensure that **Centered** is selected in the **Alignment** box.
7. Click **OK**. The dialog is closed and the type of the selected connection is displayed as centered below the connection.

8. Click in the model background to deselect the model items.
Your model now looks like this:

1. Launch scheduled
2. CRM system supports
3. Find addresses of potential customers
4. Addresses of customers found
5. Find contact person
6. Contact person found
7. Schedule product presentation
8. Product presentation appointed

Carried out by Distribution
4.11 Apply template

You can use templates that you can modify or create yourself to change the appearance of your models. For example, you can adapt the representation to your corporate design or prepare it for presentation purposes.

The Standard template is already assigned to your EPC. In the following, you will assign the Standard (classic) template to the EPC. The template enlarges the objects and brightens the colors.

Procedure
1. Click in the model background.
2. Activate the Format tab bar.
3. Click Template and select Standard (classic) to assign the template. When you are asked if the template should to be applied to all occurrences in the current model, click Yes.
The template is applied to the model.

You can make further changes to the model’s appearance. Right-click in the model background and select **Format > [Representation]**.
4.12  Save model

To save your work, click [Save]. The model is saved in the main group of the Sales and Marketing database.
5 Evaluate

This chapter describes how relevant data is output by models.

5.1 Print model

You can configure the print output of the model using the following settings.

5.1.1 Configure header and footer

To add more information to the print output than is contained in the model, you can place data in the header and footer. In the following, you will display the model name and the current date in the header of the expression and the page number and Sales and Marketing in the footer.

Procedure

1. Click ARIS > Print > Page setup. The Page setup dialog opens. You can specify all of the settings for printing the model here.
2. Ensure that the **Header and footer** entry is selected on the **Selection** tab.

3. Change **Global settings** to **Local settings**. To do this, click the down arrow in the first input box, and select **Local settings**. All other input boxes will become available for you to specify your settings.

4. Click in the left Header box.

5. Double-click in the list **Model and database attributes** on the entry **Name (Model, AT_Name)** to transfer it to the header.

6. Click in the right field of the header and then double-click **Date** in the **Other attributes** list.

7. Click in the left field of the footer and double-click **Page** in the **Other attributes** list.

8. Click in the right field of the footer and enter **Sales and Marketing**.

9. Enable the **Separate headers and footers with lines** check box.

10. Click **OK**.

Your settings are displayed in the print preview.

Tip

You can hide the header and footer in the printout and then show it again by clicking the **Insert headers/footers** icon in the **Print preview** dialog.
5.1.2 Specify print scale and color

You will now set the print size and color settings for the model.

Procedure

1. Click ARIS > Print > Print preview.

2. If you don’t want your model to be printed in color, click in the dialog toolbar on Black and white. The print preview and the print output both show the model in black and white.

3. Click Fit to page, to optimize the print scale. This action also changes the print page display in the model window.

Tip

You can align the model on a print page by moving it. To do this, exit print preview by clicking Close. Right-click in the model background and select Select > Select all. Click in the selection, hold down the mouse button, and drag the model to the relevant position. Use the print page minor tick marks to monitor the position of the model. Finally, click in the model background to deselect all symbols.

5.1.3 Start printing

You can check your settings before you start printing with the Print preview dialog. The model appears as it will when printed.

Procedure

1. If you have already closed the Print preview dialog, click ARIS > Print > Print preview again.

2. Check your settings and make the required changes.

3. Click Print. The Print dialog opens.

4. Specify the required printer settings.

5. Click OK. The model is printed on the selected printer.

6. Close the print preview.

Tip

To print a model from the model window directly without a print preview beforehand, click File > Print.
5.2 Evaluate model contents

Report-based evaluations enable you to output the contents of user databases and models or object descriptions as a text. In the following, you will evaluate the contents of the Customer acquisition model.

Procedure
1. Activate the Evaluate tab bar.
2. Click Start report. The Report Wizard guides you through the relevant steps.

3. Select Output objects in the sequence of modeling (model graph) in the Report box.
4. Click Next.
5. Retain the settings for the language and the evaluation filter.
6. Select Rich Text Format (*.rtf) as the output format.
7. Enter a name for the report and specify where it is to be stored.
8. If necessary, enable the Display result check box.
9. Click Finish.
10. After starting the report, the Select output options dialog is displayed. Click OK to accept the settings.
The report is created and output in your RTF editor.

11. Close the RTF Editor.
You just carried out your first model evaluation.
5.3 Close model

You have created and evaluated the model. Now you can close the model.

Procedure

1. Click **Close** on the model tab.

2. Click **Yes**, if you want to save your changes.

   The model is saved and the model window is closed.
6 Legal information

6.1 Documentation scope

The information provided describes the settings and features as they were at the time of publishing. Since documentation and software are subject to different production cycles, the description of settings and features may differ from actual settings and features. Information about discrepancies is provided in the Release Notes that accompany the product. Please read the Release Notes and take the information into account when installing, setting up, and using the product.

If you want to install technical and/or business system functions without Software AG's consulting services, you require extensive knowledge of the system to be installed, its intended purpose, the target systems, and their various dependencies. Due to the number of platforms and interdependent hardware and software configurations, we can only describe specific installations. It is not possible to document all settings and dependencies.

When you combine various technologies, please observe the manufacturers' instructions, particularly announcements concerning releases on their Internet pages. We cannot guarantee proper functioning and installation of approved third-party systems and do not support them. Always follow the instructions provided in the installation manuals of the relevant manufacturers. If you experience difficulties, please contact the relevant manufacturer.

If you need help installing third-party systems, contact your local Software AG sales organization. Please note that this type of manufacturer-specific or customer-specific customization is not covered by the standard Software AG software maintenance agreement and can be performed only on special request and agreement.

If a description refers to a specific ARIS product, the product is named. If this is not the case, names for ARIS products are used as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Includes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARIS products</td>
<td>Refers to all products to which the license regulations of Software AG standard software apply.</td>
</tr>
<tr>
<td>ARIS Clients</td>
<td>Refers to all programs that access shared databases via ARIS Server, such as ARIS Architect or ARIS Designer.</td>
</tr>
<tr>
<td>ARIS Download clients</td>
<td>Refers to ARIS clients that can be accessed using a browser.</td>
</tr>
</tbody>
</table>
6.2 Data protection

Software AG products provide functionality with respect to processing of personal data according to the EU General Data Protection Regulation (GDPR).

Where applicable, appropriate steps are documented in the respective administration documentation.

6.3 Disclaimer

ARIS products are intended and developed for use by persons. Automated processes, such as the generation of content and the import of objects/artifacts via interfaces, can lead to an outsized amount of data, and their execution may exceed processing capacities and physical limits. For example, processing capacities are exceeded if models and diagrams transcend the size of the modeling area or an extremely high number of processing operations is started simultaneously. Physical limits may be exceeded if the memory available is not sufficient for the execution of operations or the storage of data.

Proper operation of ARIS products requires the availability of a reliable and fast network connection. Networks with insufficient response time will reduce system performance and may cause timeouts.

If ARIS products are used in a virtual environment, sufficient resources must be available there in order to avoid the risk of overbooking.

The system was tested using scenarios that included 100,000 groups (folders), 100,000 users, and 1,000,000 modeling artifacts. It supports a modeling area of 25 square meters.

If projects or repositories are larger than the maximum size allowed, a powerful functionality is available to break them down into smaller, more manageable parts.

Some restrictions may apply when working with process administration, ARIS Administration, ARIS document storage, and ARIS Process Board, and when generating executable processes. Process Governance has been tested and approved for 1000 parallel process instances. However, the number may vary depending on process complexity, for example, if custom reports are integrated.

ARIS document storage was tested with 40,000 document items. We recommend monitoring the number and overall size of stored document items and archiving some document items if needed.